Curl Global Community
CDE 8.0のバグ? - Printable Version

+- Curl Global Community (http://communities.curl.com)
+-- Forum: Discussions (http://communities.curl.com/forumdisplay.php?fid=1)
+--- Forum: General Curl questions (http://communities.curl.com/forumdisplay.php?fid=2)
+--- Thread: CDE 8.0のバグ? (/showthread.php?tid=263)

Pages: 1 2


CDE 8.0のバグ? - nmyzk - 08-31-2011

CDE 8.0を先程から試しているのですが、
パッケージの新規作成が上手く出来ません。

Eclipse上で「新規作成→Curl パッケージファイル」としても
ファイルが作成されないのですが同じ現象が出ている方居ますか?

ちなみに環境は以下の通りです。

CDE 8.0 PRO試用版
Eclipse Pleiades 3.5.x
Windows XP SP3です。



RE: CDE 8.0のバグ? - nasuB - 08-31-2011

Eclipse3.6だけど、いっぱいできた。。。






-B
-B
-B
-B
-B


RE: CDE 8.0のバグ? - dankom - 08-31-2011

ふーむ、変ですね。

当方の環境では正常にパッケージファイル(load.scurl)が作成されました。
(エクスプローラ上でもファイルの存在の確認、Eclipse上でもパッケージが構成され、
load.scurlが認識されている)

Eclipse SDK
Version: 3.5.0
Build id: I20090611-1540

Curl® 実行環境
ビルド:8.0.0

エラーとか出てませんか?
ファイルが作成されないのはエクスプローラ上確認したのですか?
それともエクリプス上にパッケージが作成(認識)され、load.scurlが
表示されないのですか?




RE: CDE 8.0のバグ? - nmyzk - 08-31-2011

nasuBさん、dankomさん
返信ありがとうございます。

エラーメッセージは出ていません。
といいますか、厳密に言うとパッケージが作れないのでなくて
パッケージを作成しようとメニューを選択すると、
そこから先に進まなくなるのです。
(「次へ」を押しても無反応だったり、
コンテキストメニューから作成しようとしても無反応だったりします。)

そういった次第でログもキャプチャも取れないのですが、
Eclipseがどこかで悪さをしてるかもしれないですね。。。

ちょっと時間を見て他の環境でも試して見ます。

お騒がせしました。
また何か情報が出てきたら報告します。



RE: CDE 8.0のバグ? - yosuga - 08-31-2011

クリーン起動したら治るかも。 eclipse.exe -clean


RE: CDE 8.0のバグ? - usami - 08-31-2011

当方も同様の現象でましたが、クリーン起動したら治りましたよ。

クリーン起動する前はこのようにテンプレート欄が出てこなくなるようです



RE: CDE 8.0のバグ? - nmyzk - 08-31-2011

(08-31-2011, 12:35 PM)usami Wrote: 当方も同様の現象でましたが、クリーン起動したら治りましたよ。

クリーン起動する前はこのようにテンプレート欄が出てこなくなるようです
usamiさん、ご連絡ありがとうございます。
クリーン起動しましたら確かに出てきました!!

どうもありがとうございました!!




RE: CDE 8.0のバグ? - okm - 09-01-2011

CDE 8をインストールしようとしたのですが、うまくいきませんでした。

Eclipse3.6.1
で、CDE7を利用していました。

CDE8へアップデートしようとして、
・IDE7のアンインストール
・PC再起動
・Eclipse起動 し、「更新の確認」から更新しようとしたら、

 An error occurred while collecting items to be installed というエラーメッセージが出てきました。

-cleanで起動したり、更新URLを削除したりいろいろ試したのですが解決されず、
メニューの" ヘルプ / Eclipse SDKについて "からCurl関連のプラグインをアンインストールして、
新規にインストールしなおすことで解決しました。
CurlのサイトにあるCDEをアンインストールというのは、IDEのアンインストールだけではだめなんでしょうか?





RE: CDE 8.0のバグ? - okm - 09-01-2011

続けてもうひとつ、すみません。

CDEでは、バージョン違いのソースはみれないのでしょうか?
CDE7のソースがみれなくなりました。
どうにかして(バージョンは7のままで)みることはできませんか?

また、「新しいプロジェクト」からAPIバージョンを「7」にして作成しても、
警告がでてしまいmanufestファイルしか表示されません。

インストールの仕方が悪かったのでしょうか??


RE: CDE 8.0のバグ? - usami - 09-01-2011

CDE8を入れてもIDE7は残るのでVer7のソースは見れますが、IDE7をアンインストールすると
Ver7のソースは見れなくなると思います。
CDE7とは別物なので、Ver7ソースを見たいときはIDE7を別途インストールしなおすと見れるでのは?
IDEはバージョン共存できてもCDEはバージョン共存できないようです。