Curl Global Community
CDEでCurlが正常に反映されない - Printable Version

+- Curl Global Community (http://communities.curl.com)
+-- Forum: Discussions (http://communities.curl.com/forumdisplay.php?fid=1)
+--- Forum: General Curl questions (http://communities.curl.com/forumdisplay.php?fid=2)
+--- Thread: CDEでCurlが正常に反映されない (/showthread.php?tid=952)



CDEでCurlが正常に反映されない - umemura - 08-08-2013

CDE起動時に、Curlのメディエータ開始時にエラーが発生します。

詳細は下記の通りです。


Failure launching mediator, command=[C:\Program Files (x86)\Curl Corporation\Surge\9\bin/surge-do --ide 0 attach-eclipse 51537 51538 ja false]
Cannot run program "C:\Program": CreateProcess error=2, Žw’肳‚ꂽƒtƒ@


再インストールしても、エラーになります。
インストールは「http://www.curl.com/cde.update-site.win32/」を指定しています。


Curl Development Tools for Eclipseのインストールに失敗しました。
Cannot run program "C:/Program": CreateProcess error=2, Žw’肳‚ꂽƒtƒ@


環境情報は以下の通りです

OS:Windows 7
Curl:Curl8.0.0
CDE:
Eclipse Java EE IDE for Web Developers.


Version: Helios Service Release 2

Build id: 20110218-0911

正常にインストールしなおすにはどうすればよいでしょうか。



RE: CDEでCurlが正常に反映されない - wara - 08-08-2013

umemura様

報告されている問題は、以下のサイトに記載されている問題だと思います。
http://www.curlap.com/release/2013/20130509.html

環境情報に”Curl8.0.0”とありますが、
最新版の”Curl8.0.3”はご使用されていないのでしょうか?

この問題は、最新版の”Curl8.0.3”のCDEを使用すれば発生しないと思います。
Curlのバージョンを”8.0.3”に上げれない場合は、上記のサイトに対応方法が
記載されておりますので、ご参照ください。


RE: CDEでCurlが正常に反映されない - dyoshida - 08-08-2013

そのエラーは今年の春頃に自分も体験した覚えが・・・
Curl公式HPのニュースリリースにお詫びが載っていたこの問題のことではないかと
http://www.curlap.com/release/2013/20130509.html

自分のところだと5月末頃にリリースされたCDEではこの問題は解消されていたと記憶しているのですが
今でもCDEをインストールし直してこの問題が起きているのでしょうか?

もし起きているのだとすると、一番トラブルが少なそうなインストール方法は、
 ・アンインストールしたものとは別にEclipseを新たに別のフォルダに展開
 ・Curl RTEもアンインストール

としてから、新しいEclipseでCDEをインストールすれば問題が起きにくい気がします。
(RTEは最新の8.0.3がインストールされますが・・・)




RE: CDEでCurlが正常に反映されない - umemura - 08-13-2013

ニュースリリースでしたか。
確認不足でした。ありがとうございます。

アンインストールを繰り返しても、Cur RTE 8.0.0 しかインストールされず、
メディエータの起動時のエラーが出続けていたのですが、
Eclipse でインストールする際に、Curlをインストールするパスを c:\curl のように、
半角スペースを入れないようにすることが必要なのですね。