Post Reply 
 
Thread Rating:
  • 120 Votes - 2.59 Average
  • 1
  • 2
  • 3
  • 4
  • 5
APIの変更について
11-11-2015, 05:53 PM
Post: #1
APIの変更について
現在CURL RTEビルド8.0.5
サポートされるAPIバージョン 8.0.5、7.0.6、4.0.8
のクライアント環境で、Curl4.0.8にて構築されたシステムを起動しようとしております。

しかし、Curl起動時に「Error: HttpMissingFileException」が出力され、実行できません。

エラー発生時のアプレットを確認するとAPI8となっているため、サーバ上にあるライセンスは4のライセンスが配置されているため出力されているのだと思われます。
クライアントの実行APIが8になっているため起動できないのだと思っておりますが、起動するAPIを4に指定するためにはどのように変更したら良いのでしょうか。

なお、CURL RTEビルド7.0.6
サポートされる API バージョン: 7.0.6, 6.0.7, 4.0.8
のクライアント環境では、アプレットの詳細確認するとAPI4で実行されているため問題なくシステムが起動されます。

CURL RTEのインストール順番?等、何か関係あるのでしょうか。

御存じの方いらっしゃれば御教示ください。
Find all posts by this user
Quote this message in a reply
11-11-2015, 06:38 PM (This post was last modified: 11-11-2015 06:39 PM by dice256.)
Post: #2
RE: APIの変更について
複数のバージョンのCurlRTEがインストールされている環境では、どのバージョンのRTEでアプレットが
実行されるかは、アプレットのCurl ヘラルドに記述されているAPI バージョン番号によって決まったと
思いますが、こちら4.0のみが記載されていますでしょうか?  例{curl 4.0 applet}

もし、{curl 8.0, 4.0 applet} のように8.0も併記されていると 8.0.5がインストールされている
環境では、API 8として実行されそうですが、そうでないとすると妙な動作な気がします。

また、ライセンスファイルはブラウザからは単にWebサーバからダウンロードしたファイルとして
扱われてブラウザがキャッシュしていることがありますが、このキャッシュファイルが破損している
場合もHttpMissingFileExceptionが発生した覚えがありますので、ブラウザのキャッシュクリアを
試してみてはいかがでしょうか。
Find all posts by this user
Quote this message in a reply
11-12-2015, 09:39 AM
Post: #3
RE: APIの変更について
早速の御回答ありがとうございます。

サーバに配置してあるソースには「{curl 4.0 applet}」と記載しております。
助言頂きましたキャッシュの削除を実行してみましたが、変わらずAPI8で実行されてしまう状況です。

RTEをインストール順番等も関係してくるのでしょうか。
Find all posts by this user
Quote this message in a reply
11-12-2015, 04:50 PM
Post: #4
RE: APIの変更について
異なるバージョンのRTEのインストールは古い順に入れるほうがインストールのトラブルは
少ないとは思いますが、ヘラルドに書かれているバージョンと異なるRTEで起動する症状は
残念ながら聞いたことがありません

エラー発生時のアプレットを確認してAPI8だったとのことですが、これは何を確認されたか
お教え頂ければなにが起こっているか予想する材料になるかもしれません。
Find all posts by this user
Quote this message in a reply
11-12-2015, 05:41 PM
Post: #5
RE: APIの変更について
独立型アプレットで構築しているのですが、curl://http~を実行した際に
「Error: HttpMissingFileException」が出力されました。
その際に、Curlコントロールパネルを立ち上げ、アプレットの表示からアプレットマネージャーを起動しました。

アプレットマネージャーの右端にAPIという項目があり、そこの情報を確認した所API8になっておりました。
問題なく動いているバージョンでは、アプレットマネージャ開いた所APIが4でしたので、実行APIが8となってしまっているために起動できないのだと思い前述の記載を投​稿した流れになります。

別途、現在の環境におけるインストールの順番については、確認してみようと思います。
Find all posts by this user
Quote this message in a reply
11-13-2015, 11:57 AM (This post was last modified: 11-13-2015 12:20 PM by dice256.)
Post: #6
RE: APIの変更について
localhostで実験してみましたが、"curl://launch"で独立型アプレットを起動中にライセンスファイルが
みつからずにエラーが発生した場合はアプレットマネージャのAPIの表示はインストールされている
最新のRTEに該当するバージョンが表示されているようです。

憶測ですが、独立型アプレットの起動は最新のRTEのモジュールで行われていて、起動まではアプレット
マネージャのAPIの表示は実際に起動するアプレットと異なる表示になっているのでは。

実験でも、ライセンスファイルを配置してアプレットが起動するようになると期待しているAPIの表示に
なりましたので、ライセンス認証時エラーの際にアプレットマネージャの表示がAPI8となっていることは
気にしないでよいのでは。

固有の端末でライセンスファイル関連のエラーが起きているならキャッシュ関連かもしれません。
Find all posts by this user
Quote this message in a reply
11-16-2015, 09:53 AM
Post: #7
RE: APIの変更について
>dice256様

アプレット起動前は最新のAPIが表示されるのですね。
確かにAPI4で動いている端末については、システムが起動後に確認しておりました。
ということは、RTE側でAPI8で認識されているわけではなさそうですね。

端末2台で試してみましたが、両端末とも同様の結果になってしまっております。
エラー端末の接続環境等を再確認してみようと思います。
もしかしたらDNS周りの設定漏れのためかもしれないですね。

dice256様に御回答頂き、Curlの影響ではないような気がしてきましたので、周辺環境再度確認してみようと思います。
Find all posts by this user
Quote this message in a reply
11-16-2015, 03:32 PM
Post: #8
RE: APIの変更について
システム起動時のエラーはネットワークまわりの問題であったことが判明しました。

エラーが発生した場合に最新のAPIが表示される事を教えて頂けましたので、別の観点から原因を突き止めることができました。
ありがとうございました。
Find all posts by this user
Quote this message in a reply
11-16-2015, 08:34 PM
Post: #9
RE: APIの変更について
Yamada様

情報共有ありがとうございます。
原因が特定できたようでなによりです。

ネットワーク関連の障害でも認証時のHttpMissingFileExceptionが起きるのですね。
今後にたような障害があったときの参考になりそうです。
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump:


User(s) browsing this thread:
1 Guest(s)