Thread Rating:
  • 333 Vote(s) - 2.91 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Eclipse4.2にUMLツールがインストールできない
07-13-2012, 06:11 PM,
#1
Eclipse4.2にUMLツールがインストールできない
CDEのV8.0.0をEclipse 4.2にインストールしようとすると次のエラーになり
インストールできません。

1 つ以上の必須項目が見つからないため、インストールを完了できません。
Software being installed: Curl Development Environment - UML Tools 5.0.0.v2011-08-05-021419-7B--8s735513J13D1375B5L (com.curl.eclipse.cde.uml.feature.feature.group 5.0.0.v2011-08-05-021419-7B--8s735513J13D1375B5L)
Missing requirement: CDE UML Extensions 5.0.0.v2011-08-05-021419 (com.curl.eclipse.cde.uml 5.0.0.v2011-08-05-021419) requires 'bundle org.eclipse.jet 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Curl Development Environment - UML Tools 5.0.0.v2011-08-05-021419-7B--8s735513J13D1375B5L (com.curl.eclipse.cde.uml.feature.feature.group 5.0.0.v2011-08-05-021419-7B--8s735513J13D1375B5L)
To: com.curl.eclipse.cde.uml [5.0.0.v2011-08-05-021419]

Caede0.9.0についても同様にインストールできません。




Attached Files
.png   Eclipse4.2エラー_V8.0.0.png (Size: 28.42 KB / Downloads: 454)
Reply
07-18-2012, 08:34 AM,
#2
RE: Eclipse4.2にUMLツールがインストールできない
Caede0.9.0も同様のエラーでしょうか?よろしくお願いいたします。
Reply
07-18-2012, 10:37 AM,
#3
RE: Eclipse4.2にUMLツールがインストールできない
caede0.9.0の場合はcaedeのスレッドで投稿したエラー内容
http://communities.curl.com/showthread.p...10#pid1410
になります。
Reply
07-19-2012, 11:12 AM,
#4
RE: Eclipse4.2にUMLツールがインストールできない
お手数をお掛けして申し訳ありません。
Eclipse 4.2のソフトウェアサイトから、UMLツールの動作に必要なプラグインが除外されてしまったことが原因です。

現状での対処方法は以下になります。
---
Window -> Preferences から設定ダイアログを開き、Install/Update -> Available Software Sites にて
1.以下の2つのソフトウェアサイトを [Add] する。
http://download.eclipse.org/modeling/m2t.../releases/

http://download.eclipse.org/modeling/mdt.../releases/

2.Juno ( http://download.eclipse.org/releases/juno ) を [Disable] にする。
(名前の前のチェックボックスのチェックが外れた状態にします)

上記設定後に通常通りに UMLツールをインストールすれば問題なく動作します。
インストール後は、2で外したチェックを戻しておいていただければとおもいます。
---

この問題は、4.2の正式サポート時に修正いたします。
Reply
07-19-2012, 01:59 PM,
#5
RE: Eclipse4.2にUMLツールがインストールできない
インストールできました。ありがとうございます。
Reply
07-19-2012, 02:17 PM,
#6
RE: Eclipse4.2にUMLツールがインストールできない
Caede0.9.0でも試してみましたが、今度はメモリアナライザがインストールできないようです。

1 つ以上の必須項目が見つからないため、インストールを完了できません。
Software being installed: Curl Development Environment - Memory Analyzer 5.0.0.v2012-07-09-032620-7B--8s735713H13L1397F73 (com.curl.eclipse.cde.mat.hprof.feature.feature.group 5.0.0.v2012-07-09-032620-7B--8s735713H13L1397F73)
Missing requirement: Memory Analyzer - Curl HPROF Adapter 5.0.0.v2012-07-09-032620 (com.curl.eclipse.cde.mat.hprof 5.0.0.v2012-07-09-032620) requires 'bundle org.eclipse.mat.ui 1.0.0' but it could not be found
Cannot satisfy dependency:
From: Curl Development Environment - Memory Analyzer 5.0.0.v2012-07-09-032620-7B--8s735713H13L1397F73 (com.curl.eclipse.cde.mat.hprof.feature.feature.group 5.0.0.v2012-07-09-032620-7B--8s735713H13L1397F73)
To: com.curl.eclipse.cde.mat.hprof [5.0.0.v2012-07-09-032620]
Reply
07-19-2012, 05:42 PM, (This post was last modified: 07-19-2012, 05:45 PM by ysugahara.)
#7
RE: Eclipse4.2にUMLツールがインストールできない
>2.Juno ( http://download.eclipse.org/releases/juno ) を [Disable] にする。
>(名前の前のチェックボックスのチェックが外れた状態にします)

上記ソフトウェアサイトは有効になっていますでしょうか。
もしチェックが入っていないようでしたら、チェックを入れた状態でインストールしてみてください。
Reply
07-20-2012, 05:09 PM,
#8
RE: Eclipse4.2にUMLツールがインストールできない
Caede0.9.0の場合もまずは通常の設定で

Curl開発環境(日本語/英語)
Curl開発環境(Caede開発環境ツール)
Curl開発環境(メモリアナライザ)

をインストール後、指定された手順にて

Curl開発環境(UMLツール)

をインストールすることによりすべてインストールすることができました。

Reply

Forum Jump:


Users browsing this thread:
1 Guest(s)

MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1017 - Can't find file: 'mybb_threadviews' (errno: 2)
Query:
INSERT INTO mybb_threadviews (tid) VALUES('562')