Thread Rating:
  • 266 Vote(s) - 2.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
アプレットがどのバージョンで動いているか
09-02-2011, 09:07 AM,
#4
RE: アプレットがどのバージョンで動いているか
何をしたいかによるかもしれませんが、バージョンによって処理を変えたい場合は api-version-switch という構文を使うのが一般的です。

Code:
{api-version-switch
    case "4+", "3.1+" do
    {define-proc {release}:String
        {return "an advanced release"}
    }
    case "3.0.1+" do
    {define-proc {release}:String
        {return "a patched 3.0 release"}
    }
    case "3.0" do
    {define-proc {release}:String
        {return "an original 3.0 release"}
    }
    else
    {define-proc {release}:String
        {return "an unknown release"}
    }
}
{text You are running {release}.}
Reply


Messages In This Thread
RE: アプレットがどのバージョンで動いているか - by fukuta - 09-02-2011, 09:07 AM
Forum Jump:


Users browsing this thread:
1 Guest(s)

MyBB SQL Error

MyBB has experienced an internal SQL error and cannot continue.

SQL Error:
1017 - Can't find file: 'mybb_threadviews' (errno: 2)
Query:
INSERT INTO mybb_threadviews (tid) VALUES('259')